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Problem:
Visual APS fails to startup, refresh or save/publish due to the following error
Server internal error occurred:
Lynq.Erp.Server.Processor.Extension.Interfaces.ExecutionInternalTypeError: Error in type 'Lynq.Erp.S...Check error logs for details. Exit Company?

Cause(s):
This type of error message can be due to a number of different reasons and the stage at which the error message is returned may help troubleshoot this further.  Whenever Visual APS returns an error to the screen the exact details of the problem are saved to log files on the computer where the software is installed.  The log files can be read by clicking on Yes to Exit Company and then by clicking on About > Open Error Log.  

Solution(s):
When the error is displayed on startup/refresh, check whether:
 
  1. User is connecting to the correct SQL server\database
  2. User is connecting with the correct authentication (Windows\SQL)
  3. User has chosen the option to connect to APS using the App Role if public only permissions are granted in SQL
  4. User has sufficient permissions in SQL to the ERP database for their chosen authentication method
  5. SQL Server is accessible from the computer where APS is installed
  6. Firewall is blocking access to SQL (standard port 1433)
  7. The ERP company APS is connecting to doesn't contain any duplicate Stock Codes, Employees, Jobs, Work Centres or Machines records.
  8. The ERP database has been restored to a point before Visual APS was initially installed.  (APS objects will be missing and the application will need re-configuring)

When the error is displayed on save and publish, the problem is more often than not, an issue with SQL permissions.  Check whether:
 
  1. User has chosen the option to connect to APS using the App Role if public only permissions are granted in SQL
  2. User has sufficient permissions in SQL to ERP database when the App Role is not in use.  Save and publish requires the user to be a member of the db_owner role



  3.